@
julyclyde @
9hills @
lhbc @
mhycy @
wy315700 @
clino @
jasontse @
wuwuyun @
la0wei @
gamexg @
anoymoux 统一感谢楼上各位的回复。
帖子中我描述的不是太详细,网络成这样并非我所愿。实际情况中有大约30个分中心,但是分中心网络并非统一规划与建设,各中心都有自己的应用系统,且相互独立。现在需要在省中心节点建立一套系统可以统一查询各个分中心的数据。
根据我的判断,各中心肯定有各式各样的私网IP地址,重复的情况肯定存在。我在图中只是列出了最极端的情况,假设全部是192.168.1.0/24。从访问需求上来说各中心无需访问省中心,只需省中心能访问到各中心。所以我计划在各中心的内部网络中架设一台路由器用来NAT省中心过来的地址。
后来问题解决了(只怪自己基础知识掌握的不够扎实),我为每个中心预留了一个C类地址做NAT。在这附上各个设备的配置:
CORE:
interface GigabitEthernet0/0
ip address 135.148.1.1 255.255.255.0
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 172.16.255.1 255.255.255.252
interface GigabitEthernet0/1.20
encapsulation dot1Q 20
ip address 172.16.255.5 255.255.255.252
interface GigabitEthernet0/1.30
encapsulation dot1Q 30
ip address 172.16.255.9 255.255.255.252
ip route 172.16.1.0 255.255.255.0 172.16.255.2
ip route 172.16.2.0 255.255.255.0 172.16.255.6
ip route 172.16.3.0 255.255.255.0 172.16.255.10
R1:
interface FastEthernet0/0
ip address 172.16.255.2 255.255.255.252
interface FastEthernet0/1
ip address 192.168.1.3 255.255.255.0
ip nat outside source static 192.168.1.2 172.16.1.1
ip route 135.148.1.0 255.255.255.0 172.16.255.1
ip route 172.16.1.1 255.255.255.255 192.168.1.2
R2:
interface FastEthernet0/0
ip address 172.16.255.6 255.255.255.252
interface FastEthernet0/1
ip address 192.168.1.3 255.255.255.0
ip nat outside source static 192.168.1.2 172.16.2.1
ip route 135.148.1.0 255.255.255.0 172.16.255.5
ip route 172.16.2.1 255.255.255.255 192.168.1.2
R3:
interface FastEthernet0/0
ip address 172.16.255.10 255.255.255.252
interface FastEthernet0/1
ip address 192.168.1.3 255.255.255.0
ip nat outside source static 192.168.1.2 172.16.3.1
ip route 135.148.1.0 255.255.255.0 172.16.255.9
ip route 172.16.3.1 255.255.255.255 192.168.1.2