V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
XuYijie
V2EX  ›  程序员

QQ 邮箱 587 端口连接失败

  •  
  •   XuYijie ·
    BubblingXuYijie · 29 天前 · 1379 次点击

    springboot 项目,465 端口是正常发送,587 连接失败,是腾讯的问题还是我配置项里面少配置了什么东西呀。 报错:Could not connect to SMTP host: smtp.qq.com, port: 587 配置文件: #邮件服务器 spring.mail.host=smtp.qq.com spring.mail.port=587 spring.mail.username= spring.mail.password= spring.mail.protocol=smtp spring.mail.properties.mail.smtp.auth=true spring.mail.properties.mail.smtp.ssl.enable=true spring.mail.properties.mail.smtp.starttls.enable=true spring.mail.properties.mail.smtp.socketFactory.port=587 spring.mail.properties.mail.smtp.socketFactory.class=javax.net.ssl.SSLSocketFactory

    10 条回复    2024-05-19 17:22:49 +08:00
    liyvhg
        1
    liyvhg  
       29 天前 via Android
    2 个端口加密方式不同,587 端口是 STARTTLS 协议的,465 端口是为 SMTPS ( SMTP-over-SSL )
    julyclyde
        2
    julyclyde  
       29 天前
    @liyvhg 看错误信息,明显不是协议区别的问题

    就是网络策略给限制了
    busier
        3
    busier  
       29 天前
    前些时也做过类似开发 用的 163 邮箱 限制要宽松些 你可以先考虑开发用 回头正式用在换
    yinmin
        4
    yinmin  
       29 天前
    587 端口是 starttls ,不是 smtp over ssl ,你改成 spring.mail.properties.mail.smtp.ssl.enable=false 再试试
    yinmin
        5
    yinmin  
       29 天前
    或者去掉这 2 行,再试试

    spring.mail.properties.mail.smtp.ssl.enable=true
    spring.mail.properties.mail.smtp.socketFactory.class=javax.net.ssl.SSLSocketFactory
    kkk9
        6
    kkk9  
       29 天前
    Could not connect to SMTP host: smtp.qq.com, port: 587

    先检查 587 端口的出站方向流量是否正常放行
    yinmin
        7
    yinmin  
       29 天前
    在 springboot 的机器上运行这条命令,检查是否能连通 smtp.qq.com:587 ,有些云服务商是封禁 25 、587 端口的
    nc -vz smtp.qq.com 587

    如果能连通,参考#4 、#5 。

    这个问题其实 AI 能给出答案,我试了 GPT-4o 、Gemini 1.5 Pro 、Claude-3-Opus 、Mistral-Large 、Qwen-1.5-110B 、Yi-Large-turbo 都给出了正确解决方案。
    XuYijie
        8
    XuYijie  
    OP
       27 天前
    去掉 ssl.enable=true 这一行可以了,棒的哈哈哈
    XuYijie
        9
    XuYijie  
    OP
       27 天前
    @liyvhg 去掉 ssl.enable=true 这一行可以了,棒的哈哈哈
    XuYijie
        10
    XuYijie  
    OP
       27 天前
    @yinmin 去掉 ssl.enable=true 这一行可以了,棒的哈哈哈
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   1381 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 17:48 · PVG 01:48 · LAX 10:48 · JFK 13:48
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.