V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
leeyuzhe
V2EX  ›  PHP

怎么把 xampp 里面的 php 版本升级为 php7

  •  
  •   leeyuzhe · 2015-06-22 03:49:07 +08:00 · 9975 次点击
    这是一个创建于 2411 天前的主题,其中的信息可能已经有所发展或是发生改变。

    google了一圈都失败了,要么没反应要么apache都启动不了了

    4 条回复    2015-06-22 13:19:20 +08:00
    vibbow
        1
    vibbow  
       2015-06-22 04:06:34 +08:00   ❤️ 1
    vibbow
        2
    vibbow  
       2015-06-22 04:07:32 +08:00
    直接用Apache的话,因为PHP是VC14编译的,所以Apache也得使用VC14编译的(或者使用FastCGI模式)
    lijianying10
        3
    lijianying10  
       2015-06-22 12:42:20 +08:00
    我觉得你需要:
    https://registry.hub.docker.com/u/coderstephen/php7/
    Docker

    希望能帮到你。
    wdd2007
        4
    wdd2007  
       2015-06-22 13:19:20 +08:00 via iPhone
    干嘛要这么折腾自己。。
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2214 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 22ms · UTC 15:28 · PVG 23:28 · LAX 07:28 · JFK 10:28
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.