V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX 提问指南
copriwolf
V2EX  ›  问与答

mac 升级 10.13High Sierra 后无法使用 vim 和 tmux

  •  
  •   copriwolf · 2017-09-28 10:25:56 +08:00 · 8638 次点击
    这是一个创建于 2455 天前的主题,其中的信息可能已经有所发展或是发生改变。

    各位有升级 mac 的系统吗? 昨晚尝试升级到最新的 10.13 发现 Vim、Tmux 和 Brew 都不正常。

    Pro-3:~ root2$ vim
    dyld: Library not loaded: /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/libruby.2.0.0.dylib
      Referenced from: /usr/local/bin/vim
      Reason: image not found
    Abort trap: 6
    

    打开 vim 就直接报错了,而 Tmux 则是命令行和输入位置对不上。

    最重要是,还是工作生产机😂

    各位又遇到类似的问题吗

    16 条回复    2017-11-17 08:16:22 +08:00
    USCONAN
        1
    USCONAN  
       2017-09-28 10:34:34 +08:00
    我這完全沒問題呀
    glues
        2
    glues  
       2017-09-28 10:37:12 +08:00
    重新安装一下 vim
    copriwolf
        3
    copriwolf  
    OP
       2017-09-28 10:42:06 +08:00
    @glues 打算用 brew 来重装,发现 brew 也宕了,重新 brew update 之后运行,显示要先升 Xcode,现在想看看 Xcode 升到 9 能不能用。
    wogong
        4
    wogong  
       2017-09-28 10:42:22 +08:00
    可能需要重新安装一下 Command Line Tools
    psklf
        5
    psklf  
       2017-09-28 10:57:08 +08:00
    Vim 好的很
    azygote
        6
    azygote  
       2017-09-28 11:13:21 +08:00
    我的 vim 也是这样,brew reinstall vim 一下就好了
    Tonni
        7
    Tonni  
       2017-09-28 11:14:52 +08:00   ❤️ 1
    我也遇到这个问题了,重装 Vim 的时候报另外的错误,到最后用 brew install python 解决的。
    20015jjw
        8
    20015jjw  
       2017-09-28 11:41:13 +08:00 via Android
    工作机也敢升级 心大
    copriwolf
        9
    copriwolf  
    OP
       2017-09-28 15:22:58 +08:00
    @azygote 感谢,通过更新 xcode,然后更新 brew,然后重装 vim 最后结局问题了。
    想问你有用 tmux 吗?好像存在一些格式上的错乱,reinstall 也不行。
    copriwolf
        10
    copriwolf  
    OP
       2017-09-28 15:23:43 +08:00
    @Tonni 感谢,我是搞到最后 brew upgrade python 才能正常重装 vim。
    想问你有用 tmux 吗?更新后的 tmux 出现了一些显示问题,reinstall 也没办法解决
    copriwolf
        11
    copriwolf  
    OP
       2017-09-28 15:24:16 +08:00   ❤️ 1
    @wogong 本质上好像是因为底层变了,所以要更新 xcode9 和 command line,然后重新安装过 vim 才能解决
    Tonni
        12
    Tonni  
       2017-09-29 09:35:52 +08:00
    @copriwolf 抱歉,我在 Mac 上面没用过 tmux,Linux 上经常用。
    mysql
        13
    mysql  
       2017-10-11 17:40:50 +08:00
    我也遇到这样的问题, 弄了一天才解决,分享下我的方法,希望可以帮到其他人

    我的 python 默认环境是 3.6 因为我装了 anaconda

    在安装了 xcode 最新版以后
    执行 brew reinstall vim
    报错如下:

    if_python.c:67:10: fatal error: 'Python.h' file not found
    #include <Python.h>
    ^~~~~~~~~~
    1 error generated.
    make[1]: *** [objects/if_python.o] Error 1
    make[1]: *** Waiting for unfinished jobs....
    make: *** [first] Error 2

    READ THIS: https://docs.brew.sh/Troubleshooting.html


    弄了半天就是装不上

    然后运行了 brew link python2

    再执行 brew reinstall vim 还是报错

    然后 执行 brew uninstall vim

    然后运行 vim 发现奇迹般的可以用了

    应该是有个坑
    thwawar
        14
    thwawar  
       2017-10-12 17:45:34 +08:00
    用楼上的方法解决了

    只要 `brew uninstall vim` 即可
    regiondavid
        15
    regiondavid  
       2017-11-15 00:11:34 +08:00
    感谢楼上的方法,成功解决问题
    mofe
        16
    mofe  
       2017-11-17 08:16:22 +08:00
    brew uninstall macvim && brew install macvim --with-lua --with-override-system-vim --with-luajit 解决了问题。。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   实用小工具   ·   3065 人在线   最高记录 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 26ms · UTC 11:55 · PVG 19:55 · LAX 04:55 · JFK 07:55
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.