V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
git
Pro Git
Atlassian Git Tutorial
Pro Git 简体中文翻译
GitX
benjunk
V2EX  ›  git

mac 的 zsh 为啥 git 提示都变成中文了,,并且 tab 分支也不行了

  •  
  •   benjunk · 2018-11-30 09:58:37 +08:00 · 5823 次点击
    这是一个创建于 1095 天前的主题,其中的信息可能已经有所发展或是发生改变。

    求助,,那天把 zsh 卸载重装过后,tab 可以提示分支了,但是提示还是中文,今天再次出现 tab 不能用,是哪个配置出问题了呢?

    12 条回复    2018-12-03 11:47:49 +08:00
    angusj
        1
    angusj   2018-11-30 10:11:18 +08:00
    使用 git 前加下面两个环境变量试试:
    LANG="en_US.UTF-8"
    LC_CTYPE="en_US.UTF-8"
    benjunk
        2
    benjunk   2018-11-30 10:17:46 +08:00
    @angusj 多谢,,export LANGUAGE=en_US.UTF-8 我用这个解决了中文问题,tab 问题我发现了,是 alias 过后的命令无法 tab,现在还在看怎么解决。
    yoshiyuki
        3
    yoshiyuki   2018-11-30 11:01:09 +08:00
    @benjunk
    alias 是 git alias 还是 zsh alias ?
    benjunk
        4
    benjunk   2018-11-30 11:18:05 +08:00
    @yoshiyuki git alias 的,比如说 git pull origin master 我用全命令,master 就可以补全。如果我给 pull origin 做了 alias 变成了 git pl mater 这个时候 master 的分支名无法被补全
    benjunk
        5
    benjunk   2018-11-30 15:48:46 +08:00
    解决问题了,,原来是那天 brew 安装别的东西给我把 git 更新到 2.19.2 了,搞不懂为啥这个版本 git 提示成中文了
    查了好多资料,把 git 卸载,又安装历史版本,现在回到 2.18.0 好了
    CrownLeo
        6
    CrownLeo   2018-12-01 12:07:55 +08:00
    @benjunk 刚去查了下, 貌似是 git 从 某一个版本开始会去读系统的 `LANG` 等系统变量来决定显示语言了, 所以你直接在 `~/.bash_profile` 里面设置 `export LANG=en_US.UTF-8` 就行了, 这里面还有一些变量优先级覆盖的问题, 我没太去仔细看
    https://stackoverflow.com/questions/10633564/how-does-one-change-the-language-of-the-command-line-interface-of-git
    benjunk
        7
    benjunk   2018-12-01 16:53:32 +08:00
    @CrownLeo 嗯嗯,多谢。
    yoshiyuki
        8
    yoshiyuki   2018-12-03 10:16:43 +08:00
    @benjunk 我感觉应该用 git pl origin master 吧
    benjunk
        9
    benjunk   2018-12-03 10:18:20 +08:00
    @yoshiyuki 肿么了?我直接 alias 了 pl 是 pull origin
    yoshiyuki
        10
    yoshiyuki   2018-12-03 10:54:10 +08:00
    @benjunk 原来如此
    benjunk
        11
    benjunk   2018-12-03 10:58:20 +08:00
    @yoshiyuki 用 brew 安装的 git 都有毒,,,alias 过一会就不能 tab 分支了,,,我还是用 mac 自带的吧
    yoshiyuki
        12
    yoshiyuki   2018-12-03 11:47:49 +08:00
    @benjunk 我一般都是用自带的。新电脑在终端输入 git 就会弹窗让你装 xcode,装完就完事了
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1617 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 17:12 · PVG 01:12 · LAX 09:12 · JFK 12:12
    ♥ Do have faith in what you're doing.