首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
宝塔
V2EX  ›  程序员

gradle jar 包版本冲突问题

  •  
  •   leonme · 33 天前 · 538 次点击
    这是一个创建于 33 天前的主题,其中的信息可能已经有所发展或是发生改变。

    gradle 默认的解决策略应该是选择有冲突的 jar 包中版本最新的一个,现在的情况是这样:

    自己引入 jackson,版本为 2.9.9。但是有个第三方库内部也用了 jackson,版本为 2.3.3

    然后项目打包之后,结果 jackson 版本为 2.9.8,请问为什么呢?版本不是应该是 2.9.9 吗?

    6 回复  |  直到 2019-10-18 08:52:21 +08:00
        1
    binbinyouliiii   33 天前
    最新版的 IDEA 可以查看 Gradle 项目的依赖关系图
        2
    leonme   33 天前 via iPhone
    @binbinyouliiii 看了依赖图,但是不能理解为啥会版本倒退
        3
    binbinyouliiii   33 天前
    @leonme #2 Gradle 不是很了解,Maven 的话不是最新为准,Gradle 大致应该类似
    复制自网上:
    依赖最短路径优先原则
    一个项目 Demo 依赖了两个 jar 包,其中 A-B-C-X(1.0) ,A-D-X(2.0)。由于 X(2.0)路径最短,所以项目使用的是 X(2.0)。

    pom 文件中申明顺序优先
    如果 A-B-X(1.0) ,A-C-X(2.0) 这样的路径长度一样怎么办呢?这样的情况下,maven 会根据 pom 文件声明的顺序加载,如果先声明了 B,后声明了 C,那就最后的依赖就会是 X(1.0)。

    覆写优先
    子 pom 内声明的优先于父 pom 中的依赖。
        4
    hkllzh   33 天前
    可以把第三方库依赖的排除,只使用自己依赖的。
        5
    leonme   33 天前 via iPhone
    @hkllzh 谢谢老哥,现在的问题不是怎么解决包冲突问题,而是不太懂 gradle 内部默认的解决包冲突的算法
        6
    leonme   33 天前 via iPhone
    @binbinyouliiii 谢谢老哥,现在的问题是 gradle 默认通过 1.0>1.8 2.0>1.8 方式来解决,很奇怪的解决方式,为啥不采用最高版本呢
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4542 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 45ms · UTC 06:07 · PVG 14:07 · LAX 22:07 · JFK 01:07
    ♥ Do have faith in what you're doing.