首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
V2EX  ›  程序员

[windows 中文输入法] 如何才能不自动切换到中文?

  •  
  •   ksc010 · 35 天前 · 1153 次点击
    这是一个创建于 35 天前的主题,其中的信息可能已经有所发展或是发生改变。
    win10 系统 原来是 有两个输入法 中文输入法+英文输入法.
    后来感觉太乱 就把英文输入删除了
    现在只有一个自带的中文输入法

    **但是**
    自带的中文(是通过 shift 切换 中文英文的, 输入法默认模式是"英文" )
    依然会在切换程序(比如编辑器切换到浏览器)的时候 输入法自己就切换到中文输入状态了
    即使切换会回编辑器 输入法依然是 中文输入状态
    万分痛苦
    第 1 条附言  ·  35 天前
    最后搞定了

    最终的设置是 就一个自带中文输入法 “微软拼音”

    然后 常规-》 输入默认模式 设置为“英文”; 最下面的 "使用以前版本的微软拼音输入法" 勾选上

    还有 另外一个地方的“允许每个应用窗口设置不同输入法” 勾选上(忘记在哪了)

    最终效果 就是 每个程序都能保持自己的输入法状态
    ps: 上面的步骤也可能不都是必须的 懒得测试了
    第 2 条附言  ·  28 天前
    又出现一个新问题
    所有的输入框 默认都是 全角的
    比如浏览器 tortoiseSVN 的提交窗口(估计因为每次都是新的窗口)

    我要放弃了 微软拼音输入法 垃圾
    21 回复  |  直到 2019-11-04 19:35:52 +08:00
        1
    Tumblr   35 天前   ♥ 1
    用小狼毫输入法的表示完全没有这样的烦恼,通过 yaml 文件定制,自由度太高了。
        2
    wafm   35 天前
    @Tumblr 太多 BUG,词库也有点傻
        3
    echo314   35 天前   ♥ 1
    高级键盘设置:允许每个应用窗口设置不同输入法。

    但是有个弊端,一旦你把软件关了,再打开,输入法又变成默认输入法了,这个不是根据应用程序分配输入法模式,确实不是完美的解决方案。
        4
    Danswerme   35 天前 via Android
    那就把英文输入法添加回来呗,切换时徽标键加空格切换,我就这么干的
        5
    wusibacg   35 天前 via Android
    @Tumblr #1 你是说默认在小狼毫下使用英文吗?这个是怎么设置的?
        6
    tankb52   35 天前   ♥ 1
    @wusibacg #5
    patch:
    "app_options/cmd.exe":
    ascii_mode: true


    大致是这样。

    不过 Rime 本身还是不太好用。
        7
    goonervs   35 天前   ♥ 1
    我用的英文 os, 自己对应一下,language preference->点击中文会出现 options->点击 keborards 里的 microsoft pinyin 出现 options->general->default mode->choose IME default mode 里可以选优先英文 /中文
        8
    CallMeReznov   35 天前
    windows 的输入法我一直搞不好,要么是重启后 IME 服务不启动,需要手动去语言设置里切换一下输入法顺序,要么是怎么都没办法用快捷键切换输入法.

    也懒得去找寻他的问题所在了,凑合用.
        9
    ksc010   35 天前
    @echo314 设置了 不顶用
        10
    echo314   35 天前
    @ksc010 我设置了,有用。
        11
    ksc010   35 天前
    @Danswerme 我感觉这样更乱
    因为好多时候不知道自己是在什么输入法发下的什么输入状态下
    也就不知道用什么快捷键切换
        12
    ksc010   35 天前
    @echo314
    我知道咋回事了
    按照 7 楼的步骤 下面有一个兼容性 勾选 "使用以前版本的微软拼音输入法"
    你说的方式就可以了
        13
    ksc010   35 天前
    @goonervs 这个我设置了
    现在怀疑是 版本兼容的问题 导致状态记不住
        14
    lzxgh621   35 天前
    设置里 中英文切换默认状态是中文 你设置为英文即可
        15
    lzxgh621   35 天前
    看漏了,你已经设置了。
    win10 小 bug 太多,重装大法好
        16
    passerbytiny   35 天前
    应该是无解,你别说切应用了,触屏模式下,仅仅是虚拟键盘关闭再重开,就变回去了。win8 以后输入法状态的宿主被从应用提取到了操作系统,从设计思想上来说,不同程序保持不同的输入法状态,说好听点是兼容性,说实际点就是个 bug (因为难做而是 BUG )。
        17
    echo314   35 天前
    @ksc010 我的是 win10 1903,并没有"使用以前版本的微软拼音输入法"的选项,这个应该是兼容性和版本的问题吧。
        18
    ksc010   35 天前
    @echo314 我的也是
    win10 专业版 1903 操作系统版本 19008.1000
        19
    lsmlive   35 天前
    shift 键,切换微软拼音里的中文输入法和英文输入法;
    win 键+空格键,切换微软拼音和美式键盘;
    这样玩游戏按到 shift 键就不会切换到中文了。
        20
    Tumblr   35 天前
    @wafm #2 目前在用 0.14.3,不管是工作电脑还是游戏电脑,都没遇到什么 bug。至于词库……Weasel 本来就不是个开箱即用的东西,傻不傻就看自己怎么调教了。

    @wusibacg #5 是的,不但在默认情况下使用英文,你甚至可以定义在哪些程序中默认用英文,哪些程序中默认用中文。
    比如我在 Windows 下,vscode,powershell 等默认英文状态,在微信、Telegram 等默认用中文状态。
        21
    hakono   35 天前 via iPhone
    @passerbytiny ???? 别什么都说是 BUG。系统输入法统一是 win7 就有的功能,只不过 win8 win10 开始变成了默认开启了
    可以在语言输入法里改回不同程序使用独立的输入法设置
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   2712 人在线   最高记录 5043   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.3 · 51ms · UTC 13:12 · PVG 21:12 · LAX 05:12 · JFK 08:12
    ♥ Do have faith in what you're doing.