V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
GeekHub
Vimax
V2EX  ›  Java

升级到 IDEA 2020.2 后经常没提示及报错修复后不会消失

  •  
  •   Vimax · 47 天前 · 1405 次点击
    这是一个创建于 47 天前的主题,其中的信息可能已经有所发展或是发生改变。

    升级到 IDEA 2020.2 后,现在写代码经常没提示了。首先是 Lombok 注解提示,经常没有提示。看警告是说 jar 版本和 idea 的插件有版本差异,看项目的 lombok 用的 springcloud 的依赖版本就没升级。这个注解也不经常写没提示也没关系。

    但是代码提示现在经常时有时无,比如缺少代码后的;号错误,加上后,错误还是有那警告(实际是没问题的)。 现在连调用枚举值这些提示都不提示。

    刚开始以为是插件装太多的问题,后面禁用了一些插件,发现还是有问题。

    排查了下:

    • 省电模式没开启
    • invalidate cache 清理了好多遍了
    • 重启 IDEA
    • 重启笔记本
    • 更新系统

    上面都操作过了,问题还是没有解决。上述问题发生后,现在感受不到 IDEA 的智能了。

    安装包用的是 linux 下的 archlinux cn 打好的包。

    IntelliJ IDEA 2020.2 (Ultimate Edition)
    Build #IU-202.6397.94, built on July 27, 2020
    For educational use only.
    Runtime version: 1.8.0_202-b08 amd64
    VM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
    Linux 5.6.19-2-manjaro
    GC: ParNew, ConcurrentMarkSweep
    Memory: 3966M
    Cores: 4
    Registry: compiler.automake.allow.when.app.running=true
    Non-Bundled Plugins: AceJump, IdeaVIM, com.intellij.ideolog, GrepConsole, HexView, Lombook Plugin, MyBatisLog, leetcode-editor, MavenRunHelper, com.zhaow.restful.toolkit, JRebelPlugin, com.ccnode.codegenerator.MyBatisCodeHelperPro
    Current Desktop: Undefined
    
    12 条回复    2020-08-13 14:52:23 +08:00
    wangyanrui
        1
    wangyanrui   47 天前   ❤️ 2
    1. lombok 的 github 上已经有人提了好几个相关的 issue 了
    2. Jetbrain 的产品,出新版本了,延迟个俩星期升级比较稳妥~ 不要第一时间升级
    Vimax
        2
    Vimax   47 天前
    @wangyanrui 谢谢。更新系统就一起 yay 更新了.
    cco
        3
    cco   47 天前
    目前跟新完没啥毛病呢?
    目前发现唯一有问题的是 mybatis log 插件,以前有个直接拷贝 sql 的选项,现在只有一个生成 SQL 的选项,不过也有可能是我新安装的 mybatisCodeHelperPro 的锅。
    zhongjun96
        4
    zhongjun96   47 天前
    jrebel debug 也会卡死了。
    Resource
        5
    Resource   47 天前
    系统更新的时候明确说了 lombok 不兼容
    Resource
        6
    Resource   47 天前
    打错了,idea 更新的时候有一行红字提示 lombok 不兼容
    Evrins
        7
    Evrins   47 天前 via iPhone
    Lomok 可以用 beta 版的,网页版可以下
    zsdroid
        9
    zsdroid   47 天前
    软件还是不要更新到最新版为好。
    我把 chrome 更新到了最新版,最近扩展各种异常。好像是因为 chrome 80+增加了安全方面的设置。
    youmilk
        10
    youmilk   47 天前
    @Evrins 哪个版本呀,0.30-EAP 好像还是有同样的问题
    lu5je0
        11
    lu5je0   47 天前
    退回 2020.1.4 吧
    Tinu
        12
    Tinu   38 天前
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1506 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 35ms · UTC 17:14 · PVG 01:14 · LAX 10:14 · JFK 13:14
    ♥ Do have faith in what you're doing.