首页   注册   登录
V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
Icex
V2EX  ›  Android

dagger1 跟 java8 有冲突?

  •  
  •   Icex · 4 天前 · 939 次点击

    dagger1 跟 java8 会有冲突吗,加入了 dagger1 时,提示使用 java8 必须把 minSdkVersion 设置为 26 以上?

    2 回复  |  直到 2020-02-14 21:26:24 +08:00
    th00000
        1
    th00000   3 天前
    目前是 dagger2 跟 java11, 没有问题, dagger1 不知道
    xingda920813
        2
    xingda920813   3 天前
    Dagger1 Java 8 还是没问题的, 我们公司项目就是 (minSdk 21). 但 Java 12 不行. 抓紧升级到 Dagger2 吧.
    关于   ·   FAQ   ·   API   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   1244 人在线   最高记录 5168   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 19:07 · PVG 03:07 · LAX 11:07 · JFK 14:07
    ♥ Do have faith in what you're doing.