V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
iOS 开发实用技术导航
NSHipster 中文版
http://nshipster.cn/
cocos2d 开源 2D 游戏引擎
http://www.cocos2d-iphone.org/
CocoaPods
http://cocoapods.org/
Google Analytics for Mobile 统计解决方案
http://code.google.com/mobile/analytics/
WWDC
https://developer.apple.com/wwdc/
Design Guides and Resources
https://developer.apple.com/design/
Transcripts of WWDC sessions
http://asciiwwdc.com
Cocoa with Love
http://cocoawithlove.com/
Cocoa Dev Central
http://cocoadevcentral.com/
NSHipster
http://nshipster.com/
Style Guides
Google Objective-C Style Guide
NYTimes Objective-C Style Guide
Useful Tools and Services
Charles Web Debugging Proxy
Smore
dushandz
V2EX  ›  iDev

iOS app 从 iOS9 开始支持的意义?

  •  
  •   dushandz · 2020-04-07 11:24:41 +08:00 · 15635 次点击
    这是一个创建于 1417 天前的主题,其中的信息可能已经有所发展或是发生改变。
    如题,不明白为啥一直要从那么低的版本开始支持,有必要吗?都是国民级 APP ?最新三个版本不行( iOS 11 iOS 12 iOS 13 这样···)?营收上有重大意义?
    48 条回复    2020-04-24 17:55:29 +08:00
    lizz666
        1
    lizz666  
       2020-04-07 11:30:03 +08:00   ❤️ 1
    我 iphone6s,用了 4 年多了,系统一直没有更新,一直是 ios9,你问我为什么?

    因为我用到的软件,ios9 都支持,比如微信,支付宝,淘宝,京东,那我为什么要升级?

    升级对我来说有什么用?很多普通用户其实心里想法跟我一样的。你在 v2 这种程序员扎堆的论坛问肯定都是支持你想法的,可是,程序员毕竟只是人口组成的非常小的一部分啊,很多其他行业的不怎么追求系统更新的人他不到万不得已真的没有去升级的动力。
    From313
        2
    From313  
       2020-04-07 11:31:15 +08:00   ❤️ 1
    我也觉得没啥意义,现在 iOS12 以下的系统占比就 6%.除非做的特别大,不然真的耗费成本做低系统兼容真的没必要.

    数字出处:https://developer.apple.com/support/app-store/
    rebounce
        3
    rebounce  
       2020-04-07 11:31:17 +08:00
    每当这个时候,把最新版本的微信支持的最低版本为基准去和产品及老板讨论。

    微信目前支持的最低版本是 iOS10
    laoyur
        4
    laoyur  
       2020-04-07 11:33:35 +08:00
    那么多依然能打,但最高 OS 版本已经止步不前的 iPad 就这样被你抛弃了?
    Lin0936
        5
    Lin0936  
       2020-04-07 11:35:46 +08:00   ❤️ 1
    放宽心吧, Android 还要支持 4.4 呢
    PureWhiteWu
        6
    PureWhiteWu  
       2020-04-07 11:39:05 +08:00
    对于一个日活 100 或者 1000 的 app,可能 6%只意味着 6 个或者 60 个人,不支持也无伤大雅。
    对于一个日活 1000W 的 app,6%意味着 60W 。
    对于一个日活 10 亿的 app,6%意味着 6000W 。
    (当然只是举个例子,实际的日活 10 亿肯定是包含了很多安卓用户的。)
    mschultz
        7
    mschultz  
       2020-04-07 11:43:38 +08:00
    @lizz666 微信早就不支持 iOS 9 了,如果你不更新系统的话注意一定不要卸载微信。我想给家里老人用的 iPad mini 1 代 2019 年 10 月重置了一次系统之后再也装不了微信了。
    shawndev
        8
    shawndev  
       2020-04-07 11:46:35 +08:00
    对于小的开发商,执拗不升级≈持有旧设备不升级( iOS9 是 6 年前的设备出场系统)≈付费意愿弱。
    对于大的开发商,比如淘宝、拼多多、携程,用户玩出花来也得用我的软件。
    什么是下沉市场,这就是下沉市场;什么是长尾理论,这就是长尾理论。
    orangy
        9
    orangy  
       2020-04-07 11:47:34 +08:00
    @From313 杠一下🤣6%是指最近 4 年内发布的 iPhone 。如果是全部 iPhone,那么是 7%;如果是全部 iPad,那么是 16%…
    butterflydog
        10
    butterflydog  
       2020-04-07 11:49:25 +08:00
    @lizz666 微信最新版 7.0.12 是要求最低 iOS10,随着微信升级,老版本微信会逐渐强制升级
    wobuhuicode
        11
    wobuhuicode  
       2020-04-07 11:54:03 +08:00
    首先 LZ 指的是国民级的 APP,在这个段位的 APP 的兼容问题不能依靠营收意义和数据去做的。最大限度兼容使用的群体才是基本原理。就像 无障碍 功能是为了营收而做的吗?不是的,是情怀驱动。
    From313
        12
    From313  
       2020-04-07 11:56:22 +08:00
    @orangy 对对对,严谨第一哈哈哈☝️
    lizz666
        13
    lizz666  
       2020-04-07 12:06:32 +08:00
    @butterflydog @mschultz

    看了下,我的微信是 7.0.9,嘿嘿
    littiefish
        14
    littiefish  
       2020-04-07 12:14:47 +08:00 via iPhone
    @mschultz 自己抓包安装
    lcandy
        15
    lcandy  
       2020-04-07 12:50:26 +08:00 via iPhone
    @mschultz 在已购项目里下载,会自动安装旧版微信
    sikong31
        16
    sikong31  
       2020-04-07 13:01:15 +08:00   ❤️ 1
    一些 app 都是从低版本就有了,开发基本都是向下兼容,成本也不是很高
    如果现在才开始做,再向前兼容,那就非常酸爽了
    icyalala
        17
    icyalala  
       2020-04-07 13:13:58 +08:00
    有些给小孩和老人用的旧设备,尤其是各种老 iPad,系统基本是不升级或者升不了级的。看你想不想争取这部分用户了。我这边有个产品在 iPad 端,iOS8 还有 10% 的量呢。。
    ipadpro4k
        18
    ipadpro4k  
       2020-04-07 13:17:37 +08:00 via iPhone
    我自个的 app 都是 13 起,佛系开发佛系购买
    across
        19
    across  
       2020-04-07 13:44:51 +08:00
    @butterflydog
    老版本还可以用吧. 我记得微博有人发过图,塞班版本的都还能用。
    xiubin
        20
    xiubin  
       2020-04-07 13:45:31 +08:00
    @lizz666 #1

    楼下并非清一色支持楼主; 不支持 iOS 9 只是新版不能使用, 旧版还是可以正常使用的. 比如微信最低支持 iOS 10, 你现在 iOS 9 仍然可用. 但是对开发来说,支持 iOS 9 维护成本就很高,很多新的接口都不能用, 测试成本也高
    guolaopi
        21
    guolaopi  
       2020-04-07 13:49:09 +08:00
    用户:原来逼我换手机的不只是手机厂商啊
    dushandz
        22
    dushandz  
    OP
       2020-04-07 13:52:05 +08:00
    @guolaopi = - = 这个不至于换手机 iOS 13 最低支持 iPhone 6s....
    dushandz
        23
    dushandz  
    OP
       2020-04-07 13:53:55 +08:00
    @dushandz 应该不至于吧 = - = 我理解 iPhone 有点类似 NS PS4 Xbox 这样的硬件的 官方升级也会尽可能多地维护支持的设备···
    BigDogWang
        24
    BigDogWang  
       2020-04-07 14:24:44 +08:00
    这个不是根据各家自己的用户来划分的吗?只要某一版本还有用户,就要兼容
    Themyth
        25
    Themyth  
       2020-04-07 14:31:06 +08:00
    看到大家在突破 ios8 ios9,我就特尴尬。。。
    我有个 ipad 第一代,现在是 IOS 4.2.1 我还能登上支付宝!
    还有一个 ipod touch 4 是 IOS6.1.2 我用来装企鹅 FM 听小说。
    一个 iphone4 在 IOS 7.1.2 我还有时候用来录音。
    一个 ipad mini 是 IOS7.1.2 我妈还在用,而且能上微信。
    mreasonyang
        26
    mreasonyang  
       2020-04-07 14:35:52 +08:00
    6% 超级多啊,在大流量公司,老接口有各位数 QPS 调用都不能直接下线的,更何况 6%
    JSheilaYB087
        27
    JSheilaYB087  
       2020-04-07 14:39:47 +08:00
    @BigDogWang 产品也可以改变用户习惯(指一些不推荐的习惯,比如:从来不升级)。
    aureole999
        28
    aureole999  
       2020-04-07 14:45:28 +08:00
    我的 iPad2 最高到 iOS 9 。
    App Store 也很 缺德,如果你装一个新 App,你之前没下载或购买过的,要求 iOS 10 以上的话就不能装,即使这个 App 旧版是可以安装在 iOS 9 上的也不行。
    得用个 iOS 10 以上的设备,安装后,再用 iOS 9 的从下载过的 App 列表里安装,就会提示最新版不兼容,但有旧版本可用,是否下载旧版本。
    santom
        29
    santom  
       2020-04-07 14:46:08 +08:00
    类比 ie9 /dog
    mxalbert1996
        30
    mxalbert1996  
       2020-04-07 14:55:43 +08:00 via Android
    @lizz666 成本问题而已,你以为像你这样的用户很多,但实际上有多少后台都是能看到的,当维护对旧版本系统支持的成本抵不过你们能创造的价值的时候你们就会被抛弃。你说的那些都是国民级的应用,影响范围广,放弃旧版本系统支持的门槛肯定会高一些,但对大多数应用来说放弃 iOS 9 并不是什么困难的决定。
    dushandz
        31
    dushandz  
    OP
       2020-04-07 15:24:38 +08:00
    @mxalbert1996 支持的成本抵不过你们能创造的价值的时候 按道理来说是这样 可是 大部分产品并不这么想吧 我感觉 iOS 9 支持的很多 APP 都很没有达到 成本 < 价值,就硬支持,别人做了我也做。
    weirdyu
        32
    weirdyu  
       2020-04-07 17:02:41 +08:00
    很多 app 是从支持 iOS8 升级上来的,有些 sdk 不支持 iOS8 了,就开始变成从 iOS9 开始了呗
    dullwit
        33
    dullwit  
       2020-04-07 17:05:51 +08:00
    不怕你笑话,我司 android 版 app 最低支持 4.0
    imswing
        34
    imswing  
       2020-04-07 17:55:40 +08:00 via iPhone
    因为苹果的设备耐用吧,有一部分用户没有升级设备导致系统也就停留在较低版本了,家里有个 iPad Mini 一代现在还能用。
    szdubinbin
        35
    szdubinbin  
       2020-04-07 19:29:50 +08:00
    其实作为开发者我也是这么想吐槽的.....但是现实是有人用没办法,用户反馈 ios9 有问题,我手头 Mac 已经最新版,xcode 已经最新版,且不能支持低版本模拟器,这时候我只能跑去借台低版本的机器去复现。
    butterflydog
        36
    butterflydog  
       2020-04-07 20:34:52 +08:00
    @across ios 平台微信 7 之前的版本都不能用了,登录不上
    tanghongkai
        37
    tanghongkai  
       2020-04-07 20:37:25 +08:00
    @mschultz 可以去已购买应用里面找,至少我的 ios10 是这样
    mschultz
        38
    mschultz  
       2020-04-07 21:10:04 +08:00
    @lcandy #15
    @tanghongkai # 37
    谢谢,原来是这样。回头有机会我试一下去。我当时的解决方法是买了个新的 iPad mini 5 😂
    maxxfire
        39
    maxxfire  
       2020-04-07 21:24:26 +08:00
    @dullwit 安卓和 iOS 完全 2 个生态,系统占比不一样
    horizonl
        40
    horizonl  
       2020-04-07 22:05:45 +08:00
    原谅我想到了正义,因为只有 1%就抛弃是不是正义?
    当然,商业因为基数少利润少而放弃小搓人无可厚非。
    lcandy
        41
    lcandy  
       2020-04-07 22:30:52 +08:00
    @mschultz #38 不过其实还是会有问题,微信会提示是旧版让你升级而无法登录,这是微信自己的限制了和苹果也没啥关系了,苹果也帮不了你,不过其他本身没有限制的软件依旧可用!
    yeshang
        42
    yeshang  
       2020-04-07 22:43:08 +08:00
    我的 ipad 是 ios8
    市面上很多 app 不能安装. 气死我了.你们的老版本在哪里
    bclerdx
        43
    bclerdx  
       2020-04-08 07:36:11 +08:00 via Android
    @Lin0936 是么?微信已经从 5.0 起步了。
    pedestrianc
        44
    pedestrianc  
       2020-04-08 11:36:10 +08:00
    作为开发告诉你,因为 ios9 之后 api 没有什么太大变化,要不早不支持了。。。
    bclerdx
        45
    bclerdx  
       2020-04-08 18:29:51 +08:00 via Android
    @pedestrianc 为什么?
    bclerdx
        46
    bclerdx  
       2020-04-08 18:33:19 +08:00 via Android
    @wobuhuicode 对。
    iyeatse
        47
    iyeatse  
       2020-04-10 13:31:43 +08:00
    我来找个角度,培训班产出的 iOS 从业人员是在 iOS 9 时代( 2015 年左右)大量出现的,如果这部分开发者不及时更新自己的知识的话,那么他们产出的 app 自然也只能从 iOS 9 起步
    BernieDu
        48
    BernieDu  
       2020-04-24 17:55:29 +08:00
    @iyeatse 那我来告诉你。升级版本号并不会导致不能编译。。
    关于   ·   帮助文档   ·   博客   ·   API   ·   FAQ   ·   我们的愿景   ·   实用小工具   ·   2334 人在线   最高记录 6543   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 29ms · UTC 01:56 · PVG 09:56 · LAX 17:56 · JFK 20:56
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.