V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
wszszh
V2EX  ›  程序员

Vue 官网提供的 cdn 地址加载的 vue 默认是 3.0.0 版本?

  •  
  •   wszszh · 2020-08-19 23:50:01 +08:00 · 4896 次点击
    这是一个创建于 679 天前的主题,其中的信息可能已经有所发展或是发生改变。

    半夜项目组来电话,页面打不开。排查一波是引入的官网文档的 cdn 地址,默认是 3.0.0 的了。

    <script src="https://cdn.jsdelivr.net/npm/vue"></script>

    https://cn.vuejs.org/v2/guide/index.html

    37 条回复    2020-08-27 21:49:36 +08:00
    yafoo
        1
    yafoo  
       2020-08-19 23:57:05 +08:00 via Android
    赞一下,3.0 要上线了估计
    RYAN0UP
        2
    RYAN0UP  
       2020-08-19 23:57:46 +08:00
    不是吧。

    ![Snipaste_2020-08-19_23-57-17.png]( https://i.loli.net/2020/08/19/2cNAVk4fsCov3WH.png)
    cydian
        3
    cydian  
       2020-08-19 23:59:40 +08:00 via Android
    我打开也是 3.0.0
    kanezeng
        4
    kanezeng  
       2020-08-19 23:59:55 +08:00
    北京联通打开,显示:
    Original file: /npm/[email protected]/dist/vue.global.js
    liuzhaowei55
        5
    liuzhaowei55  
       2020-08-20 00:00:51 +08:00 via Android
    这个月要正式上线了
    yuzo555
        6
    yuzo555  
       2020-08-20 00:05:47 +08:00
    用 jsdelivr 请务必指定版本
    hronro
        7
    hronro  
       2020-08-20 01:03:09 +08:00
    jsdelivr 在国内速度怎样啊?
    Biwood
        8
    Biwood  
       2020-08-20 05:30:20 +08:00 via iPhone
    Trim21
        9
    Trim21  
       2020-08-20 06:23:45 +08:00 via Android
    还是写死版本号吧,就不用这么担惊受怕了
    yuzo555
        10
    yuzo555  
       2020-08-20 07:49:01 +08:00
    @hronro 很好用,网宿的节点,国内外最好用的公共 CDN 。
    Hoye
        11
    Hoye  
       2020-08-20 09:06:55 +08:00   ❤️ 1
    哦豁,想喷 vue 结果发现是自己的问题- -。可太难受了
    wangritian
        12
    wangritian  
       2020-08-20 09:38:11 +08:00
    引用外部依赖一定要带上版本
    dingjs
        13
    dingjs  
       2020-08-20 09:42:54 +08:00
    官方文档上确实提供的是这个链接

    <!-- production version, optimized for size and speed -->
    <script src="https://cdn.jsdelivr.net/npm/vue"></script>
    zhuweiyou
        14
    zhuweiyou  
       2020-08-20 09:45:58 +08:00   ❤️ 1
    你自己不指定版本,逗。
    en20
        15
    en20  
       2020-08-20 09:50:50 +08:00
    你这就像把 .lock 文件扔 .gitignore 一样
    Qcui
        16
    Qcui  
       2020-08-20 09:52:02 +08:00
    @Biwood <!-- 开发环境版本,包含了有帮助的命令行警告 -->
    <script src="https://cdn.jsdelivr.net/npm/vue/dist/vue.js"></script>
    或者:

    <!-- 生产环境版本,优化了尺寸和速度 -->
    <script src="https://cdn.jsdelivr.net/npm/vue"></script>

    官网给的链接,不过这俩链接打开都是 2.6.11 版本呀。
    上面说不指定版本的,官网建议就没指定,可以给他们提出来,冷嘲热讽怕不是。。。
    Maboroshii
        17
    Maboroshii  
       2020-08-20 09:56:35 +08:00
    我也遇到了,也是用的官网教程里的链接,然后去换了个指定版本的 CDN 就好了。。挺坑的
    Ritter
        18
    Ritter  
       2020-08-20 09:59:36 +08:00
    昨晚看了确实是 3 版本 不过早上又恢复 2 版本了
    wzq001
        19
    wzq001  
       2020-08-20 10:32:01 +08:00
    Vue.js v2.6.11
    qwerthhusn
        20
    qwerthhusn  
       2020-08-20 11:38:56 +08:00
    前端项目,指定依赖库的地址,要缀上具体版本号

    https://cdn.jsdelivr.net/npm/[email protected]

    后台运行的各种 docker 容器,全部指定上小版本号,不用 latest 或者大版本号这种 tag

    一个 major 版本升级,如果没有做 API 向后兼容,直接能搞垮一个项目
    Balthild
        21
    Balthild  
       2020-08-20 13:53:41 +08:00 via iPhone
    重点在于这是官方文档提供的地址,要批评不加版本号也应该批评文档吧
    ccyu220
        22
    ccyu220  
       2020-08-20 14:24:48 +08:00
    @Balthild 人家那个也就是个文档推荐学习的 CDN,也没让你生产环境用啊。
    shuax
        23
    shuax  
       2020-08-20 14:43:10 +08:00
    /*!
    * Vue.js v2.6.11
    * (c) 2014-2019 Evan You
    * Released under the MIT License.
    */
    coolcoffee
        24
    coolcoffee  
       2020-08-20 15:02:31 +08:00
    npm/vue 形式会走 latest tag,我看 latest 还是 2.6.11 。

    连大版本都不锁的都是厉害了
    ccbikai
        25
    ccbikai  
       2020-08-20 16:48:58 +08:00
    你们真的在生产环境用 jsdelivr ?
    crs0910
        26
    crs0910  
       2020-08-20 18:18:40 +08:00
    应该是发布事故吧
    fengxianqi
        27
    fengxianqi  
       2020-08-20 19:58:01 +08:00 via Android
    生产不能用 jsdelivr 吗
    agdhole
        28
    agdhole  
       2020-08-20 20:07:49 +08:00
    感觉是 jsdelivr 的 bug? beta 怎么就自动 latest 了呢
    MyouiSouth
        29
    MyouiSouth  
       2020-08-20 20:16:14 +08:00
    上面说文档有问题的,文档里明明写了

    “对于制作原型或学习,你可以这样使用最新版本”
    “对于生产环境,我们推荐链接到一个明确的版本号和构建文件,以避免新版本造成的不可预期的破坏”
    dvaknheo
        30
    dvaknheo  
       2020-08-20 23:53:01 +08:00
    就这么一点大小,为什么 不内嵌而要外链呢?
    wangyzj
        31
    wangyzj  
       2020-08-21 00:12:36 +08:00
    2.6.11
    himself65
        32
    himself65  
       2020-08-21 01:48:08 +08:00 via iPhone
    真开发不会连锁版本号都不懂吧……前端真就娱乐圈了?
    ragnaroks
        33
    ragnaroks  
       2020-08-21 09:30:46 +08:00
    正式环境应该把所有依赖资源打包发布
    OHyn
        34
    OHyn  
       2020-08-21 15:50:53 +08:00
    2.6.12 发布了,3.0 正式版估计快了。。
    CloudnuY
        35
    CloudnuY  
       2020-08-21 16:18:06 +08:00
    Balthild
        36
    Balthild  
       2020-08-21 22:19:56 +08:00
    j717273419
        37
    j717273419  
       2020-08-27 21:49:36 +08:00
    vue.js 发了 2.6.12 版本,但是没有任何说明???

    会不会跟这个事件有关???

    https://github.com/vuejs/vue/releases/tag/v2.6.12
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   4304 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 27ms · UTC 03:29 · PVG 11:29 · LAX 20:29 · JFK 23:29
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.