V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
vtoex0000000002
V2EX  ›  宽带症候群

关于单臂路由,重启 wan 口或重启单臂路由,导致 client 获取多个 v6,不能联网问题。

  •  
  •   vtoex0000000002 · 205 天前 · 1249 次点击
    这是一个创建于 205 天前的主题,其中的信息可能已经有所发展或是发生改变。

    RT ,

    单臂路由 :pppoe 拨号,dns , 网关 ,地址 192.168.1.2

    主路由: 提供 wifi ,地址 192.168.1.1

    该模式下,重启 wan 口或重启单臂路由,导致 client 获取多个 v6 ,从而导致不能联网问题。

    调试一天后,没找到解决办法。

    昨晚,想能不能用旁路路由实现?

    将 pppoe 拨号放到主路由上,其他不变。注意:单臂路由 lan 口配置网关 192.168.1.1 ,否则单臂路由无法联网。(再配置 lan6 ,dncpv6 client 获取 v6 ,做不做无所谓,如果单臂路由不需要 v6 地址)。

    网络拓扑比较简单: 光猫-->lan 口-->n1 盒子

    主路由:我用的是 hs8145x6 的光猫,直接用光猫的千兆网卡和 wifi 做主路由。

    单臂路由 n1 ,刷 op ,network 如下:

    config interface 'lan'
            option proto 'static'
            option netmask '255.255.255.0'
            option device 'eth0'
            option ip6ifaceid 'random'
            option ip6assign '64'
            option ipaddr '192.168.1.2'
            option gateway '192.168.1.1'
    
    config device
            option name 'eth0'
            option mtu '1500'
            option mtu6 '1500'
    
    config device
            option name 'vpn-client'
    
    config interface 'lan6'
            option proto 'dhcpv6'
            option reqaddress 'try'
            option reqprefix 'auto'
            option device 'eth0'
            option ip6assign '64'
            option ip6ifaceid 'random'
            option peerdns '0'
    

    dhcp

    
    config dhcp 'lan'
            option interface 'lan'
            option ra_management '1'
            option start '100'
            option limit '150'
            option force '1'
            option leasetime '1d'
            list ra_flags 'none'
    

    这样,v6 地址的获取是从主路由获取,v4 从单臂路由获取。 单臂路由和主路由负载均衡分布,有利于提升设备利用率,提升上网速率。

    目前尚无回复
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   981 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 24ms · UTC 21:55 · PVG 05:55 · LAX 14:55 · JFK 17:55
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.