V2EX = way to explore
V2EX 是一个关于分享和探索的地方
现在注册
已注册用户请  登录
测试工具
SmokePing
IPv6 访问测试
stabc
V2EX  ›  宽带症候群

一个奇怪的问题:所有 IP 都能 ping 通,但所有网站都打不开

  •  
  •   stabc · 2020-02-09 14:05:55 +08:00 · 4577 次点击
    这是一个创建于 968 天前的主题,其中的信息可能已经有所发展或是发生改变。

    Win10 系统。装了 WSL。

    出现问题时: Ping 任何网站都通,DNS 也能解析。 但就是打不开网页,全空白。 ssh 也不能用, wget 也不能用, ssh 和 wget 都返回同一个带有"invalid argument"的错误。

    用了 netsh winsock reset 重启后能恢复,但是大概几个小时左右,又继续出现这个问题,然后又要重启。谁知道什么原因?

    19 条回复    2020-02-12 15:39:41 +08:00
    leehomsf
        1
    leehomsf  
       2020-02-09 14:22:08 +08:00
    重置下网络设置
    haozi1986
        2
    haozi1986  
       2020-02-09 14:22:54 +08:00
    确定 DNS 没问题?
    Oysmart
        3
    Oysmart  
       2020-02-09 14:25:52 +08:00
    估计是代理问题了。到 IE 下检查一下系统代理。
    stabc
        4
    stabc  
    OP
       2020-02-09 14:36:49 +08:00
    @Oysmart 不止浏览器的问题,是所有的应用连接都出问题


    @haozi1986 DNS 完全没问题,ping baidu.com 正常。
    trepwq
        5
    trepwq  
       2020-02-09 14:37:57 +08:00 via iPhone
    mtu 检查一下,可以 ping 大包测试
    md5
        6
    md5  
       2020-02-09 14:42:56 +08:00 via iPhone
    看描述像是被什么代理软件劫持了,然后代理又不能正常工作,排查下
    cev2
        7
    cev2  
       2020-02-09 18:41:19 +08:00
    网游加速器、wegame 之类的装过没
    dangyuluo
        8
    dangyuluo  
       2020-02-09 18:50:20 +08:00
    换虚拟机先排除运营商问题
    ClericPy
        9
    ClericPy  
       2020-02-09 18:51:50 +08:00
    想起 wegame 导致的劫持 LSP 等网络驱动了...

    腾讯 WEGAME 导致 wsl 网络故障, 执行完重启:
    sc delete QqGameMasterControl


    能不能帮到你我也不知道了
    LiYanHong
        10
    LiYanHong  
       2020-02-09 19:08:22 +08:00
    以前学校校园网装客户端,经常出现这种情况,应该是能操作网络底层的什么程序引起的
    stabc
        11
    stabc  
    OP
       2020-02-09 19:22:45 +08:00
    @dangyuluo 运营商应该没问题,因为手机可以正常上网。


    @ClericPy 没装 wegame,只在 WSL 里装了开发相关,node, expo 等
    rekulas
        12
    rekulas  
       2020-02-09 19:27:02 +08:00
    tracert 看看有没有异常
    vocaloid
        13
    vocaloid  
       2020-02-09 20:32:17 +08:00
    是不是开了什么奇怪的系统代理
    RouJiANG14
        14
    RouJiANG14  
       2020-02-09 21:04:36 +08:00
    代理忘关???
    kokutou
        15
    kokutou  
       2020-02-09 21:11:03 +08:00
    曾经确实遇到过这种问题。。。

    几千个电脑就 3-4 台这样,

    代理没问题,所有国产软件全部卸载了,winsock 重置了。dns 没问题,网络没问题,ip 也没问题。浏览器也没问题。禁用-启用网卡没用,卸载安装网卡也没用。所有可能跟网络有关的软件都卸载了。
    ping 能 ping 通,nslookup 能解析。但是就是网页打不开。
    什么操作都不用做,重启就能好,几个小时后又坏,这样循环。

    最后只能重装了系统。。。。。。
    lz 参考下。。。。。。

    我怀疑是有奇怪的木马或者病毒或者后门。。。
    easylee
        16
    easylee  
       2020-02-09 21:17:11 +08:00
    本地时间对吗?
    CallMeReznov
        17
    CallMeReznov  
       2020-02-09 22:42:20 +08:00
    看样子很像是典型的 LSP 问题.
    不一定是 WEGAY,各种代理软件都有可能造成.
    执行一下 netsh intfa tcp reset 试一下
    stabc
        18
    stabc  
    OP
       2020-02-11 02:23:29 +08:00
    貌似解决了。之前在 WSL 里安装了 expo,然后启动后过一段时间就出这个连网问题。
    现在在 windows 下直接安装并运行 expo,目前一天多了无异常。
    ungrown
        19
    ungrown  
       2020-02-12 15:39:41 +08:00
    winsock 和 LSP 这俩真的是满地小坑,反正我是写了几个批处理专门拿来重置,一旦遇到问题就按 win 键敲脚本名然后回车
    关于   ·   帮助文档   ·   API   ·   FAQ   ·   我们的愿景   ·   广告投放   ·   感谢   ·   实用小工具   ·   958 人在线   最高记录 5497   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 41ms · UTC 19:22 · PVG 03:22 · LAX 12:22 · JFK 15:22
    Developed with CodeLauncher
    ♥ Do have faith in what you're doing.